Halterung für RAID-Karte

Hier könnt Ihr eure Projekte vorstellen die Ihr grade gedruckt habt oder plant. Die Projekte sollten entweder mit dem Drucker RF1000 oder seine Nachfolger grdruckt worden sein (oder Erweiterungen aller Art für den RFx000). Infomationen, Diskussionen und Fragen erwünscht.
Forumsregeln
Die Teile/Modelle/Bilder/Download ect dürfen nur für private Zwecke verwendet werden und sind hier ausdrücklich unter der Creative Commons Namensnennung-Nicht kommerziell 3.0 Lizenz veröffentlicht. Das Urheberrecht bleibt beim Uploader/Ersteller. Das bedeutet das die Verwendung und Veränderung der Dateien erlaubt ist und die Weitergabe NUR unter dieser Lizenz erlaubt ist. Komerzielle Nutzung der Daten ist verboten. Wer damit nicht enverstanden ist, soll bitte keine Daten hoch- oder runterladen.
Antworten
Benutzeravatar
rf1k_mjh11
Developer
Developer
Beiträge: 2065
Registriert: Di 6. Jan 2015, 19:44
Wohnort: Autriche
Has thanked: 268 times
Been thanked: 544 times

Halterung für RAID-Karte

Beitrag von rf1k_mjh11 »

Hallo,

In letzter Zeit ist es verhältnismäßig still geworden im Forum. Offensichtlich sind viele abgeschreckt worden.
Zu den Osterfeiertagen biete ich wieder einen umfangreichen Beitrag. Die mich kennen, werden sich schon Getränke bereitstellen.

Vor nicht ganz zwei Jahren (im Mai, 2022) hatte ich Probleme mit meinem Hardware-RAID. Um nicht zu sehr ins Detail zu gehen, ein HW-RAID ist ein Stück Hardware für den Computer. Daran hängen meist mehrere Festplatten.
RAID gibt es auch auf Software Basis. Das Betriebssystem, bzw. die Software (meist ein Treiber), die unter dem Betriebssystem läuft, regelt das Ganze. Bekommt das Betriebssystem was ab, sind die Daten auf den Platten futsch.
Ein Hardware-RAID regelt das hingegen selbstständig, unabhängig vom Betriebssystem. Verabschiedet sich Windows (trotz eurem vom Herzen kommenden Verneinung so einer Situation muss ich sagen: so was soll gelegentlich vorkommen), also, streikt Windows, kann man mit einem anderen System, Linux oder gar bootbarem USB, den Rechner hochfahren und auf die Daten zugreifen und gegebenenfalls sichern.
Ich hatte so ein HW-RAID an die 9-10 Jahre laufen, zu meiner vollsten Zufriedenheit. Als die Probleme erstmals auftauchten, wurden alle Laufwerke gesichert. Danach ging es an die Analyse. Es hätte ein loser Stecker oder kaputtes Kabel sein können. Leider stellte sich heraus, dass die Platine langsam am Sterben war. Ersatz musste her.
Erstaunt stellte ich fest, dass das Original nicht mehr erhältlich war (ein DC-7515). Dieser sah so aus:
OriginalRAID.jpg
Es passte schön in ein 3.5” Schacht des Rechners und zeigte permanent optische Informationen über den jeweiligen Betriebszustand. Bis zu 5 Laufwerke lassen sich anschließen, ich hatte aber nur 4 angeschlossen.
Das gute Stück wurde seinerzeit beim großen C gekauft. Nach 3-4 Jahren wurde ein zweites gekauft, für den Rechner der Lebensgefährtin.

Stunden-, nein, tagelang wurde im Netz nach dem Modell gesucht, vergeblich. Andere Lösungen kamen für mich aus verschiedenen Gründen nicht in Betracht (Software-RAID, oder die RAID Funktion der Systemplatine).
Endlich fand ich etwas von dem ich überzeugt war, es wäre zum alten RAID kompatible. Es hatte die gleichen Spezifikationen (Chip, Anzahl der Anschlüsse, mitgelieferter Software, usw.). Es sah aber so aus:
NewRAID.jpg
Sieht deutlich anders aus als das Original. Das Ding ist vorgesehen zum Einbau in einem Slot (Steckplatz). Guckt man jedoch genau hin, sieht man, dass keine Verbindung zur Systemplatine vorgesehen ist (es ist keine PCI Express Lasche vorhanden!). Ich war so überzeugt, dass es kompatible war, dass ich gleich 3 Stück vom Chinesen bestellte (eines für sofort, eines als zukünftigen Ersatz für die inzwischen 7 Jahre alte Einheit im Rechner der Lebensgefährtin, und eines als Reserve).

Dazwischen kam der Urlaub.

Einige Zeit nach dem Urlaub kam die Lieferung endlich an. :good:
Ich arbeitete in der Zwischenzeit eher mit einem alten Laptop und nur, wenn absolut nötig, mit dem PC. Denn von den 4 Laufwerken in meinem RAID liefen nur mehr 3 (würde ein zweites ausfallen, wären die Daten futsch – na ja, gesichert waren sie ja schon, aber alle neueren Daten wären futsch!). Alle vier Festplatten waren in Ordnung, die RAID Hardware hatte aber leider bei einem Anschluss ein Problem.

Als erstes wurden die Festplatten an die neue Karte angeschlossen. Hier musste ich schon vorsichtig sein. Die Reihenfolge ist nicht wie man erwarten würde. :evil:
Im Bild oben, würden die Festplattenanschlüsse von links nach rechts so lauten:
2, 3, 1, 4, 5 (oder auch: B, C, A, D, E)

Da war außer einer kleinen Bezeichnung auf der neuen Platine nichts zu sehen. Anhand der sichtbaren Nummerierung der LED hat sich die ungewöhnliche Reihenfolge ergeben.

Beim alten RAID waren diese Stecker deutlich beschriftet und schön der Reihe nach.

Somit musste ich die erste Platte an den 3. Stecker, die 2. Platte an den 1. Stecker, usw. anschließen. Ich wollte die Reihenfolge keinesfalls durcheinander bringen, denn sonst könnte es sein, dass ich sämtliche Daten neu schreiben müsste. Das wollte ich mir sparen. Daher die besondere Vorsicht. :S :blink:

Der Rechner wurde dann eingeschaltet und ohne ganz hoch zu fahren gleich ins BIOS gewechselt um die Situation zu prüfen.
Jawohl, das Laufwerk wurde im BIOS von der Systemplatine erkannt. (Das RAID wird vom BIOS wie eine physische Festplatte behandelt.) Die Bezeichnung war auch so wie mit dem Original-RAID. OK, Schweiß abwischen und Puls senken lassen. :tanzen: Das Schlimmste wäre damit geschafft. Später stellte sich heraus, dass auch alle Daten vorhanden waren. :freu:

Auch wegen der blinkenden LEDs war ich zuversichtlich. Das zuvor ausgefallene Laufwerk zeigte beinahe permanenten Lese-/Schreibzugriff, was der automatischen Restaurierung des RAIDs geschuldet war. (Wenn eine Platte getauscht wurde oder werden muss, stellt sich das RAID automatisch wieder her indem es das neue Laufwerk wieder beschreibt – dann leuchtet das ‘Lese-/Schreibzugriff-LED‘ einige Stunden dauernd.)

Da wir von den LEDs sprechen, hier die Funktion: Einmal gibt es ein LED welches den Anschluss des Moduls oder der Karte an die Systemplatine anzeigt. Ein LED leuchtet bei Schreib- oder Lesezugriff auf das eigentliche RAID. Dann gibt es pro angeschlossenem Laufwerk zwei LEDs. Eines leuchtet, falls eine Festplatte angeschlossen ist (leuchtet also im Normalfall dauernd). Das andere leuchtet nur während eines Schreib- oder Lesezugriffs auf das spezifische Laufwerk. Beim alten RAID waren diese LEDs grün und gelb (gelb beim Schreiben/Lesen). Alle diese LEDs waren beim alten von vorne sichtbar und somit gut prüfbar. Idiotischerweise sind diese laufwerks-spezifischen LEDs am neuen RAID auf der Platine selbst und sind im eingebauten Zustand von außen nicht sichtbar (außer man hat einen ge-pimpten Rechner mit Plexiglasgehäuse, der noch dazu frei steht). Auch sind diese LEDs rot und blau (=Lesen/Schreiben). Das Status-LED (ob das RAID überhaupt angeschlossen ist) und das generelle Schreib-/Lese-LED wären beim neuen RAID nur von hinten einsehbar. Somit wären diese LEDs alle für’n Ar… :dash:

Eine Lösung war in Sicht (die hatte ich schon vor der Bestellung des Ersatzes anvisiert):
Die RAID-Karte nicht in einem Slot einbauen, sondern von vorne in ein 3.5“ Schacht, wie ein Laufwerk, und die Signale der Laufwerks-LEDs per Lichtleiter ebenfalls nach vorne führen.

Dazu war einiges an CAD Arbeit nötig. Das wollte ich mir nicht am Laptop antun. Also wurde die RAID Karte provisorisch an den Desktop Rechner montiert. Das sah so aus:
TempSolution.jpg
Der Stromanschluss und die SATA Kabel wurden alle aus dem Rechnergehäuse hinausgeführt und die Platine zwischen Plexiglas und Hartfaserplatte berührungssicher montiert. Dort hing es dann frei herunter.
So arbeitete ich mehrere Wochen.
Von meinem Ausflug in die Welt der Drehgeber (siehe hier und genauer, hier) hatte ich noch einiges an Lichtleiterkabel (sogenannte POF). Das wollte ich hier einsetzen.

Als erstes galt es, die Platine möglichst exakt in CAD nachzuempfinden. Bei den kleinen Bauteilen und Abmessungen würde exaktes arbeiten nötig sein (die LEDs, in SMD Bauweise, sind 0.8x1.6mm groß). Da bleibt wenig Spielraum für Abweichungen.

Die Platine sieht in CAD so aus:
CircuitBoard_CAD.jpg
Die wichtigen Komponenten, die LEDs, Stecker und Bohrungen, sind in der richtigen Position vorhanden. Einige weitere Komponenten, die später Bedeutung fanden (sie waren im Weg oder mussten ausgewichen werden) wurden im CAD nicht erfasst.

Es wurde ein eigener Teil entwickelt, der die insgesamt 10 POF-Leitungen in die exakt richtige Position über der Platine halten sollte, jeweils möglichst exakt über den 10 LEDs.
Ein zusätzliches Stück, dass die Abmaße eines 3.5“ Einschubs hatte, würde Platine samt POF-Halter halten.

Wie immer gab es einige Iterationen. Schließlich kam dieser POF-Halter heraus:
LightGuide.jpg
Es ist halb-transparent dargestellt um die ‘Innereien‘ besser sehen zu können. Es fehlen die einzelnen POF-Leiter. Diese wurden nie gezeichnet. Die POF haben einen Außendurchmesser von ca. 2.2mm (schwarze ‘Isolierung‘), der eigentliche Lichtleiter hat ca. 1mm Durchmesser.
Damit hat das Eintrittsloch über den Laufwerks-LEDs nur wenig über 1mm Durchmesser. Der Mittenabstand der jeweiligen LED Paare ist nur 2mm. Somit müssten die POF-Kabel praktisch aneinander liegen. Alles in Allem recht eng halt. Tüfteln war angesagt.
Nachdem das CAD-Modell fertig war, wurde es auch gedruckt. Anfangs in schwarzem PLA. PLA, da sich das sehr leicht drucken lässt. Zurzeit werkelt auch so ein Teil bei mir im Rechner (also schon seit 1 1/2 Jahren). Vor einigen Monaten kam mir allerdings eine der Iterationen unter die Finger, wo die POF auch montiert waren. Mir fiel auf, dass sich das Teil deutlich verzogen hatte – wegen der Dauerspannung und vielleicht erhöhter Temperatur. Das war nicht unbedingt vertrauenerweckend. Jedenfalls habe ich jetzt beide Teile in PETG nachgedruckt, zwecks der besseren Beständigkeit der Temperatur gegenüber.

Dummerweise hatte ich nur mehr ein wenig weißes PETG, noch weniger schwarzes PETG und dafür eine neue, volle Spule PETG, grün transparent. Ich wollte nicht unbedingt ein transparentes Material nehmen, da die LEDs unter Umständen sich gegenseitig ‘ausleuchten‘. Aber was soll’s. Ich plante den kleinen Rest an schwarz gezielt einzusetzen und nur dort, wo es wichtig war, zu verwenden. Damit wurde für beide Teile ein Farbwechsel mitten im Druck notwendig.

Der POF-Halter sieht jetzt so aus:
LighGuide&POF.jpg
Ansicht von unten, wo man gut den schwarzen Teil sieht. Die hellen Punkte in den schwarzen Flächen sind die Lichtleiter Eingänge, die das Streulicht von links herleiten.
Von oben nicht so interessant:
LighGuide&POF_topView.jpg

Auf der Platine sitzt es so:
LightGuide&CircuitBoard.jpg
Die Stecker für die Laufwerke 2 und 3 (B & C) sind gerade noch zugänglich.

Die gesamte Einheit, mit 3.5“ Einschubteil, sieht so aus, leider etwas unscharf. Am rechten Rand sieht man einen schmalen schwarzen Strich – zweifärbig gedruckt:
CompleteAssy_topView.jpg
Ein letztes Bild noch – aus der Richtung, die man sieht, wenn das Ding einmal eingebaut ist:
CompleteAssy_frontView.jpg
Bei der Konstruktion des POF-Halters versuchte ich die Herstellervorgabe einzuhalten, wo keine Biegeradien unter 10mm zulässig sind. Zusätzlich war ich in der Höhe begrenzt (3.5“ Einschub!). Dadurch musste ich die POF-Leitungen schräg laufen lassen.
Wie gesagt, seit ca. September 2022 ist so ein Ding bei mir am Laufen. Das hier im Bild, in transparent grün, allerdings noch nicht. Das ist die Reserve.

Frohes Eiersuchen,

mjh11
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
RF1000 (seit 2014) mit:
  Pico Hot End (mit eigenem Bauteil- und Hot End Lüfter)
  Ceran Bett
  FW RF.01.47 (von Conrad, modif.)

Die Natur kontert immer sofort mit einem besseren Idioten.
Antworten

Zurück zu „Projekte“